All Collections
Hiring Managers
Understanding Question types, Languages, and Frameworks
What are the different programming languages and frameworks supported by WeCP?
What are the different programming languages and frameworks supported by WeCP?
Priyanka Khandagale avatar
Written by Priyanka Khandagale
Updated over a week ago

LEARNING OUTCOME

The hiring managers and Recruiters will learn about the languages and the frameworks supported by WeCP.

WeCP supports a wide range of Programming languages, Database and scripting languages, languages that support Data Science/Machine Learning, and many different Frameworks. You can choose from any of these languages to curate and customize your Tests and Coding Challenges.

You can refer to the following table for further details:

Category

Language / Framework

Version

Programming Languages
​
​

C

6.30

C++

6.3.0

C#

5.10.0.160

C++14

latest

C++11

latest

Bash

4.3

COBOL

1.1.0

Clojure

1.9.0

Scala

2.11

F#

4.5

Javascript

8.10.0

Java7/8

1.8.0

Nodejs

8.10.0

Fortran

latest

Golang

1.13

Haskell

(ghc 8.6.5, lts-14.7)

Kotlin

1.3.50

Lua

5.3.3

Objective C

GCC 4.7.2

Ruby

2.3

R

3.6.1

Swift

5.0.1

Perl and Perl6

5.22.1

Python 2/3

3.5.2

Pascal

3.0.4

Text

latest

PHP

7.0.30

Swift

4.0.3

Typescript

latest

Assembler

latest

Ada

GNU Ada compiler 4.9.3

Brainf**k

latest

Common Lisp

latest

D

2.088.0

Erlang

latest

Icon

latest

Intercal

latest

PyPy

2.7.13 v7.1.1

PyPy3

latest

Nice

latest

Rust

1.39.0

Julia

latest

Nim

0.20.2

Exilir

1.9.1

Racket

7.4

GNU Octave

4.2.2

Groovy

2.5.8

Go

1.10.1

Frameworks

Angular

latest

React

latest

MEAN

latest

MERN

latest

Nodejs

latest

ASP.NET

latest

Java Spring

latest

Python Django

latest

Python Flask

latest

Python FastAPI

latest

Ruby on Rails

latest

Database and Scripting languages

MySQL

latest

SQL

latest

SQLite

latest

Perl

v5.22.1

Data Science / Machine learning

Python

3.8.0

R

3.2.3

NumPy

1.17.4

Pandas

0.25.3

scikit-learn

0.21.3

scipy

1.3.3

imbalanced-learn

0.4.3

gensim

3.8.1

nltk

3.4.5

caret

6.0-86

tidyverse

1.3.0

Statsmodel

v0.12.2

Tensorflow

v2.5.0

Keras

2.4.0

All the versions are backward compatible.
​
​Note: If you want to include a new language in your package, you can directly contact your customer success manager.

Did this answer your question?